Support Forums
USB Driver issue with new Microsoft surface pro

Hi, I had dex2 and delogger installed and running fine on a previous laptop with win10. I have just upgraded to a new surface pro, and I am getting an error for the usb driver . In device manager the following info is displayed for the DT8x datalogger

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

{Bad Image}
%hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x

I have tried uninstalling the driver and reinstalling as administrator, also tried running in compatibility mode. (Dtusbpackage102), Any ideas on how to get this working? thanks

Hi, I had dex2 and delogger installed and running fine on a previous laptop with win10. I have just upgraded to a new surface pro, and I am getting an error for the usb driver . In device manager the following info is displayed for the DT8x datalogger Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39) {Bad Image} %hs is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0x I have tried uninstalling the driver and reinstalling as administrator, also tried running in compatibility mode. (Dtusbpackage102), Any ideas on how to get this working? thanks

Hi justinhuntress,

Error code 39 is a bit tricky to solve; please uninstall the driver from the device manager, make sure no USB cable is connected to your computer before reinstalling a fresh download of DTUsb. Would you please check if you can use a different USB port?

Best regards,
dataTaker Expert

Hi justinhuntress, Error code 39 is a bit tricky to solve; please uninstall the driver from the device manager, make sure no USB cable is connected to your computer before reinstalling a fresh download of DTUsb. Would you please check if you can use a different USB port? Best regards, dataTaker Expert

Hello,

just wanted to tell u guys, that i have the same problem with a Panasonic Toughbook CF-20 Win10 right now. I already talked to my IT-Guy, but till now we dont know how to solve this problem.

Best regards,
Markus

Hello, just wanted to tell u guys, that i have the same problem with a Panasonic Toughbook CF-20 Win10 right now. I already talked to my IT-Guy, but till now we dont know how to solve this problem. Best regards, Markus

Hi MarkH,

When you install the DTUsb, it always starts with USB driver installation before installing DTUsb. The windows will blink for a second, showing a command prompt window before getting into confirmation windows of 2 USB drivers.

If you did not see the driver installation window, something might obstruct the installation. You can try to use Windows troubleshooter, reinstalling the driver using the "Update driver" option from Device Manager, or cleaning the installation remnant from the registry before reinstallation. The latter has risk; I won't post any registry key; please consult with your IT.

The USB driver itself is FTDI version 2.06.00; you can find it from the FTDI website. It may work if you can reinstall separately from DTUsb, but I can't guarantee it.
https://www.ftdichip.com/Drivers/CDM/Win2k/CDM%202.06.00%20WHQL%20Certified.zip

Best regards,
dataTaker Expert

Hi MarkH, When you install the DTUsb, it always starts with USB driver installation before installing DTUsb. The windows will blink for a second, showing a command prompt window before getting into confirmation windows of 2 USB drivers. If you did not see the driver installation window, something might obstruct the installation. You can try to use Windows troubleshooter, reinstalling the driver using the "Update driver" option from Device Manager, or cleaning the installation remnant from the registry before reinstallation. The latter has risk; I won't post any registry key; please consult with your IT. The USB driver itself is FTDI version 2.06.00; you can find it from the FTDI website. It may work if you can reinstall separately from DTUsb, but I can't guarantee it. https://www.ftdichip.com/Drivers/CDM/Win2k/CDM%202.06.00%20WHQL%20Certified.zip Best regards, dataTaker Expert

Hello dTExpert,

thnks again. I gave this information to my IT-Guy. Let´s see if he can get dtUSB to work.

Best regards,
Markus

Hello dTExpert, thnks again. I gave this information to my IT-Guy. Let´s see if he can get dtUSB to work. Best regards, Markus

Hello dTExpert,

today we tried ur approach and we got one step further. Thnks for that :) ... Now its possible to open dtUSb, but when i plug in the DataTaker i can only here the windows notification sound and thats it. Normally i see a little DataTaker symbol and the Browser opens (the Launch browser box is marked). In the device manager i have the error code 39 at the DataTaker usb port. Any ideas?

Best regards,

Markus

Hello dTExpert, today we tried ur approach and we got one step further. Thnks for that :) ... Now its possible to open dtUSb, but when i plug in the DataTaker i can only here the windows notification sound and thats it. Normally i see a little DataTaker symbol and the Browser opens (the Launch browser box is marked). In the device manager i have the error code 39 at the DataTaker usb port. Any ideas? Best regards, Markus

Hello DtExpert, I have tried your solution but basically the same issue as MarkH is describing. seems to be compatibility issue with USB 3. Unfortunately I only have 2 x USB 3 ports. So in the meantime I am using my old laptop to run datataker and delogger. Hope there will be a solution to this. Also I tried the link you supplied for the driver, but still no joy. Its like windows is overriding the driver that is within DTusb. And using some generic driver. Under the events tab in device manager is states 'Device USB\VID_0403&PID_D000\10661400602b requires further installation.'
When I try to update driver manually and direct to the Dtusb or the FTDchip driver you linked on here windows says ' Windows has determined that the best driver is already installed' So frustrating. So it thinks its the best driver, yet it has an Asterix next to it and wont connect! Damn u windows!!

Hello DtExpert, I have tried your solution but basically the same issue as MarkH is describing. seems to be compatibility issue with USB 3. Unfortunately I only have 2 x USB 3 ports. So in the meantime I am using my old laptop to run datataker and delogger. Hope there will be a solution to this. Also I tried the link you supplied for the driver, but still no joy. Its like windows is overriding the driver that is within DTusb. And using some generic driver. Under the events tab in device manager is states 'Device USB\VID_0403&PID_D000\10661400602b requires further installation.' When I try to update driver manually and direct to the Dtusb or the FTDchip driver you linked on here windows says ' Windows has determined that the best driver is already installed' So frustrating. So it thinks its the best driver, yet it has an Asterix next to it and wont connect! Damn u windows!!

Hi Markus and justinhuntress,

I try to cross-reference the solution with Microsoft; unfortunately, most of them modify the registry to get it working again. That is quite a risky solution, so I do not like to go down that path unless you know what you do.

Would you please try one more attempt? Uninstall the DTUsb, then install the USB driver on its own and run DeTransfer. Device Manager would show you the connection as COM, so check the COM number and set it up in DeTransfer connection. If you manage to get the connection, reinstall DTUsb.

Best regards,
dataTaker Expert.

Hi Markus and justinhuntress, I try to cross-reference the solution with Microsoft; unfortunately, most of them modify the registry to get it working again. That is quite a risky solution, so I do not like to go down that path unless you know what you do. Would you please try one more attempt? Uninstall the DTUsb, then install the USB driver on its own and run DeTransfer. Device Manager would show you the connection as COM, so check the COM number and set it up in DeTransfer connection. If you manage to get the connection, reinstall DTUsb. Best regards, dataTaker Expert.

Hey DtExpert, ok I have tried that, but windows just seems to make its own mind up as soon as the unit is plugged, can't even get a port number to configure. This is a new computer and am happy to mod registry as I have nothing to loose, apart from OS lol. Can I pls have that info?

Hey DtExpert, ok I have tried that, but windows just seems to make its own mind up as soon as the unit is plugged, can't even get a port number to configure. This is a new computer and am happy to mod registry as I have nothing to loose, apart from OS lol. Can I pls have that info?

Hi justinhuntress

You can open up the registry location of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{36fc9e60-c465-11cf-8056-444553540000}

That key is controlling the USB port, then deletes the entries of UpperFilters and LowerFilters (you may find both or only one of them).

You can also try to uninstall the driver (not only within Ports but also in the USB controllers type) and restart the computer before reinstalling the driver.

Best regards,
dataTaker Expert

Hi justinhuntress You can open up the registry location of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36fc9e60-c465-11cf-8056-444553540000} That key is controlling the USB port, then deletes the entries of UpperFilters and LowerFilters (you may find both or only one of them). You can also try to uninstall the driver (not only within Ports but also in the USB controllers type) and restart the computer before reinstalling the driver. Best regards, dataTaker Expert
edited Aug 3 at 2:48 am

Hi Dtexpert, I didnt have upper or lower in the registry. Tried uninstall and restart, still the same. Under 'events' tab it states USB/VID required further installation. Are you able to get your hands on a newish surface pro to try?

Hi Dtexpert, I didnt have upper or lower in the registry. Tried uninstall and restart, still the same. Under 'events' tab it states USB/VID required further installation. Are you able to get your hands on a newish surface pro to try?

Hi justrinhuntress,

Please send a request email to [email protected]; I will send a direct response from my email then I can assist you remotely. Would you please prepare to install TeamViewer software as I will use it to assist you remotely?

Notes:
There is a restriction on getting a new OS on my PC, it is possible, but it will take a long route since I need to get permission and assistance (related to centralized OS update setting) on setting up two OS.

Best regards,
dataTaker Expert

Hi justrinhuntress, Please send a request email to [email protected]; I will send a direct response from my email then I can assist you remotely. Would you please prepare to install TeamViewer software as I will use it to assist you remotely? Notes: There is a restriction on getting a new OS on my PC, it is possible, but it will take a long route since I need to get permission and assistance (related to centralized OS update setting) on setting up two OS. Best regards, dataTaker Expert

Hello dT-Expert,

sadly i still have the problem so i wanted to ask, if u found the problem and fixed justin´s computer. Maybe it will work for mine too.

Best regards,
Markus

Hello dT-Expert, sadly i still have the problem so i wanted to ask, if u found the problem and fixed justin´s computer. Maybe it will work for mine too. Best regards, Markus
103
12
3
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
With selected deselect posts show selected posts
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft